Eclipse Pro Hardware Requirements

Eclipse Pro Hardware Requirements

Eclipse Pro requires Eclipse Classic at least version 4.1.162 to be installed, configured, and fully operational. In addition, it has the following hardware requirements.

ItemServer RecommendedServer MinimumAgent RecommendedAgent MinimumNotes
Architecturex64x64x64x32Eclipse Pro Agent can run on 32 or 64 bit. Server requires 64 bit.
OSWindows 10 or Windows Server 2016 (or greater)Windows 7 SP1 or Windows Server 2008 R2 SP1Windows 10 or Windows Server 2016 (or greater)Windows XP SP3Windows Server 2012 R2 specifically has known issues, involving performance problems, that have been observed exclusively on this OS. It should be avoided.
RAM8GB (or more)4GB4GB2GBThe Eclipse Pro Server service benefits from additional RAM to a point. This depends on the number of machines and activity level.
HDD* dependsEclipse Pro Server will use up to 3-4X the disk space used by the Eclipse Classic application.
CPUi7i5 or fasterEclipse Pro Server is multi-threaded and would benefit from faster CPU with multiple cores to a point. The Eclipse Pro Agent service adds a minimal CPU burden to the Eclipse-COMM application but the entire system (including Eclipse Classic) will run better on a faster CPU.